Nissan GT-R Forum banner
1 - 20 of 27 Posts

·
Registered
Joined
·
284 Posts
Discussion Starter · #1 ·
Midpipe & Std ECU = Problem???
If you have a midpipe and factory ecu (only) do you get an Engine Warning Light?
I have a midpipe and Factory ecu and have had the Eng Warning light come on.25.71%
I have a midpipe and Factory ecu and have NEVER had the Eng Warning light come on.3394.29%
 

·
Registered
Joined
·
284 Posts
Discussion Starter · #2 ·
First time putting up a poll, hope it appears.

I am getting the engine warning light come on regularly, it is an air/fuel ratio error from what Nissan tell me, anyone else with the Factory ECU only (ie. not a Cobb) get this?
Cheers.
 

·
Founder/Admin
Joined
·
26,277 Posts
First time putting up a poll, hope it appears.

I am getting the engine warning light come on regularly, it is an air/fuel ratio error from what Nissan tell me, anyone else with the Factory ECU only (ie. not a Cobb) get this?
Cheers.
a midpipe is not causing this.. it is replaced past the 02 sensors and will not cause this warning

do you have aftermarket intakes?
 

·
Registered
Joined
·
284 Posts
Discussion Starter · #5 ·
Nope, car is 100% std other than midpipe
 

·
Registered
Joined
·
420 Posts
I have a 2012 with an AAM resonated midpipe only and I have this issue. The light came on the day after I had the pipe installed. BTW...I was told the same thing (a/f ratio) from my Nissan dealer. They told me it wasn't a big deal though.
 

·
Registered
Joined
·
284 Posts
"I have a 2012 with an AAM resonated midpipe only and I have this issue. The light came on the day after I had the pipe installed. BTW...I was told the same thing (a/f ratio) from my Nissan dealer."

Aha bingo. Light may go off over night but randomly comes back. I have only driven it for 4 days since it originally came on.
 

·
R33 Member
Joined
·
958 Posts
Would love to hear esp from 2012 re: above as I am considering getting AAM res midpipe. Thanks.
 

·
Founder/Admin
Joined
·
26,277 Posts
I have a 2012 with an AAM resonated midpipe only and I have this issue. The light came on the day after I had the pipe installed. BTW...I was told the same thing (a/f ratio) from my Nissan dealer. They told me it wasn't a big deal though.
thats strange ive never heard of that in the over 3 years the car has been out and the midpipe is the most common thing done to the car.... i dont understand how the exhaust exiting more freely could affect a/f ratio something that is measured before the midpipe... you should in theory for arguments sake be able to drive around with no exhaust and not get a warning...
 

·
SF Bay Area Member
Joined
·
548 Posts
I have a 2012 with AAM non resonated mid pipe and no CEL thus far....knock on wood!
 

·
Registered
Joined
·
862 Posts
I have always heard that you should disconnect the battery during an exhaust installation so that the computer will be cleared and will relearn and adapt immediately. Could it be that installer left the battery connected and now it was comparing the new flow with the old flow and coming up with a big enough deviation to log a CEL?

Tom
 

·
Founder/Admin
Joined
·
26,277 Posts
yeah its not the battery disconnect the ECU doesn't work like that

could it be a weird coincidence of the gas cap wasnt tightened the same day the pipe was put on.... sounds dumb i know..but something else has to be going on here
 

·
Super Moderator
Joined
·
3,612 Posts
I'm not part of the Poll because I had a mid-pipe put on after an E-Tune. But, for what it's worth, never an error code with that single physical mod.

Alexd
(2012)
 
1 - 20 of 27 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top